This incident has been resolved. We have confirmed that instance rates have returned to normal and connectors are now syncing successfully.
Incident Summary Description: We identified an issue for Shopify which resulted in syncs failing with an Access denied for fileErrors field error.
Timeline: This issue began on Sep 29, 2025 around 7:30 PM UTC and was resolved on Sep 30, 2025 at 4:00 AM UTC.
Cause: The issue occurred due to a recent code change made in response to Shopify’s Order returns API failures.
Resolution: A hotfix was deployed to address the issue by modifying the code logic. Following this change, the connectors resumed syncing successfully.
Posted Sep 30, 2025 - 05:06 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 30, 2025 - 03:51 UTC
Update
We have identified the root cause of the issue causing Shopify connectors failure. A fix is currently in progress, and we will provide further updates soon.
Posted Sep 30, 2025 - 01:26 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Sep 29, 2025 - 23:45 UTC
This incident affected: Sales connectors (Shopify).