3rd Party: Qualtrics Connections Intermittently Failing to Sync /Ticket-Exports Endpoint Due to 500 Internal Server Error and 404 Not Found Errors From the Source API
This incident has been resolved. We have observed that instance rates have returned to normal levels and affected connectors are syncing successfully.
Incident Summary Description: We identified an issue for Qualtrics, which resulted in syncs failing with a 500 Internal Server Error or 404 Not Found Error.
Timeline: This issue began on 2025-03-31 at 05:15:00 UTC and was resolved on 2025-04-02 at 06:25:00 UTC.
Cause: The source API began returning frequent 500 and 404 errors on the '/ticket_exports' endpoint.
Resolution: Our engineers deployed a change to include more robust re-try logic when encountering these errors. This has resolved the sync errors. Qualtrics is still investigating the root cause on their side.
Posted Apr 04, 2025 - 16:35 UTC
Update
We are still awaiting a response from Qualtrics Support regarding this issue. In the meantime, we have deployed a workaround to help prevent failures. As a result, the failure rate has significantly decreased following the deployment. We will continue to monitor the situation and provide further updates.
Posted Apr 02, 2025 - 04:36 UTC
Update
We are continuing to investigate this issue.
Posted Apr 01, 2025 - 20:00 UTC
Investigating
We are currently investigating this issue with the Qualtircs support team.
Posted Apr 01, 2025 - 15:49 UTC
This incident affected: Support connectors (Qualtrics).