Fivetran: Connection Failures in MDLS Destinations for AWS us-east-1 region

Incident Report for Fivetran

Resolved

Incident Summary:

Description:
Sync failures were observed for Managed Data Lake destinations in the AWS us-east-1 region. Affected connectors experienced elevated 404 errors due to issues in handling incoming files during parallel request processing.

Timeline:
This issue began on Oct 01, 2025, at 02:00 UTC and was resolved on Oct 01, 2025, at 19:00 UTC.

Cause:
A recent configuration change led to authentication errors and failures in accessing necessary incoming files, resulting in downstream 404 errors for sync requests.

Resolution:
A fix was deployed to correct the job routing logic and restore expected behavior. Affected connectors should succeed on the next attempt, requiring no manual intervention.
Posted Oct 01, 2025 - 19:07 UTC

Monitoring

A fix has been deployed for the identified issue. Initial monitoring indicates a drop in the number of affected connections. We will continue to observe the connections for full stability.
Posted Oct 01, 2025 - 14:03 UTC

Update

The service is experiencing failures due to a delay in retrieving necessary AWS authentication credentials. We are continuing to work on a resolution for this issue.
Posted Oct 01, 2025 - 06:03 UTC

Identified

Sync failures impacting data transfer to MDLS Destinations within the AWS us-east-1 region have been identified and are being addressed.
Posted Oct 01, 2025 - 02:00 UTC
This incident affected: Systems (General Services).