Some connectors are failing with the error: "DestinationWorkerStopRetryException: java.lang.IllegalArgumentException: Column list contains duplicate name hashes."

Incident Report for Fivetran

Resolved

The fix has returned all affected connectors to their normal functionality and the incident has been resolved.
Posted May 30, 2024 - 22:12 UTC

Monitoring

A fix has been released to correct the code logic and prevent duplicate hash values. Connectors are no longer experiencing this failure and are expected to sync normally.

We will continue to monitor the situation until we confirm it is fully resolved.
Posted May 30, 2024 - 19:14 UTC

Identified

We have identified an issue where some connectors are failing due to duplicate column name hashes. The error present is:
"DestinationWorkerStopRetryException: java.lang.IllegalArgumentException: Column list contains duplicate name hashes."

Our developer has identified the root cause and is currently working on a solution.
Posted May 30, 2024 - 18:12 UTC
This incident affected: File connectors (Amazon S3).