Fivetran: AWS Lambda connections which sync through S3 bucket are failing

Incident Report for Fivetran

Resolved

We have resolved this incident.
Posted Feb 13, 2025 - 15:45 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2025 - 12:45 UTC

Update

We have identified an issue where AWS Lambda connectors are failing with a "Improper JSON formatted data in the S3 bucket. Expected BEGIN_OBJECT but was STRING at line 1 column 3 path" exception. We are currently investigating in more detail and will provide additional updates accordingly.
Posted Feb 13, 2025 - 10:53 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Feb 13, 2025 - 10:30 UTC
This incident affected: Function connectors (AWS Lambda).