3rd Party: Quickstart and dbt Core transformations are failing with the error "No macro named 'assert_not_null' found"

Incident Report for Fivetran

Resolved

Incident Summary

Description:
We have identified an issue where the Quickstart and dbt Core transformations are failing with the error "No macro named 'assert_not_null' found"

Timeline:
The issue started on December 4, 2025, at 09:25 UTC and was resolved on December 4, 2025, around 11:00 UTC.

Cause:
A recent release (https://hub.getdbt.com/dbt-labs/spark_utils/0.3.1/) on the DBT side caused these failures.

Resolution:
DBT fixed the issue with the new release (https://github.com/dbt-labs/spark-utils/releases/tag/0.3.2), resulting in the successful transformation runs.
Posted Dec 04, 2025 - 12:24 UTC

Monitoring

A recent release (https://hub.getdbt.com/dbt-labs/spark_utils/0.3.1/) on the DBT side caused these failures. DBT fixed the issue with the new release (https://github.com/dbt-labs/spark-utils/releases/tag/0.3.2). The transformations are recovering. We will keep monitoring all impacted transformations.
Posted Dec 04, 2025 - 11:43 UTC

Identified

We have identified an issue where the Quickstart and dbt Core transformations are failing with the error "No macro named 'assert_not_null' found". We are working to resolve it
Posted Dec 04, 2025 - 11:15 UTC
This incident affected: Systems (Transformations).