Fivetran: Connectors Are Failing in Multiple Regions with the error "com.fivetran.donkey.decoupled.DestinationWorkerStopRetryException"
Incident Report for Fivetran
Resolved
We have resolved this incident.
Posted May 30, 2024 - 17:27 UTC
Update
We have identified there are still connectors failing due to a similar issue related to duplicate column name hashes. The error present is:
"DestinationWorkerStopRetryException: java.lang.IllegalArgumentException: Column list contains duplicate name hashes.".
Posted May 30, 2024 - 15:57 UTC
Monitoring
A fix has been released to roll back the change that caused this issue. Connectors are no longer experiencing this failure and are expected to be syncing again as normal.

We will continue to monitor until we confirm this is fully resolved.
Posted May 30, 2024 - 14:27 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 30, 2024 - 14:19 UTC
Update
We have identified the potential cause as an internal change that prevented PK columns containing null values from being properly processed during hashing. We are investigating further and working on a solution.

The error for the connector contains: "com.fivetran.donkey.decoupled.DestinationWorkerStopRetryException: java.lang.IllegalArgumentException: Primary key column doesn't have a value: 1"

Further updates will be provided within 1.5 hours.
Posted May 30, 2024 - 14:10 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted May 30, 2024 - 13:47 UTC
This incident affected: Systems (General Services).