Fivetran: Connection syncs are delayed.

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that connection syncs are running on schedule now.

Incident Summary
Description:
We identified an issue with sync schedules, which resulted in syncs getting delayed.

Timeline:
Incident start date: 2025-05-07 15:30 UTC
Incident end date: 2025-05-07 17:30 UTC

Cause:
A code bug was identified that had caused delays in connection sync schedules.

Resolution:
We rolled back the changes to restore the service.
Posted May 07, 2025 - 19:14 UTC

Monitoring

We have deployed a fix for the issue affecting connection sync schedules. We are starting to observe that some connections have resumed syncing at their scheduled times.

We will continue to monitor all affected connectors until they return to their normal sync functionality.
Posted May 07, 2025 - 18:09 UTC

Identified

We have identified that this issue was caused by the internal scheduler, and we are currently working on a fix.
Posted May 07, 2025 - 17:08 UTC
This incident affected: Systems (General Services).