3rd Party: Snapchat Ads connections are failing with error "500 Internal Server Error"

Incident Report for Fivetran

Resolved

This incident has been resolved. We observed that Snapchat Ads connection sync success rates have returned to normal levels, and syncs are now running as expected.

Description:
We identified an issue where Snapchat Ads connections started failing with error "500 Internal Server Error"

Timeline:
The issue began on March 18, 2026, at 04:03 UTC and was resolved on March 18th, 2026, at 05:01 UTC.

Cause:
The issue was caused by an intermittent issue with a third-party API service that resulted in 500 errors.

Resolution:
No changes were required on our side. The issue was automatically resolved on the third-party side, and syncs are back to normal.
Posted Mar 18, 2026 - 06:49 UTC

Monitoring

We experienced an intermittent issue with a third-party API service that resulted in 500 errors. Connections are now recovering, and we are continuing to closely monitor sync performance.
Posted Mar 18, 2026 - 06:13 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Mar 18, 2026 - 05:50 UTC
This incident affected: Marketing connectors (Snapchat Ads).