Incident: 3rd Party: 3rd Party: Qualtrics Connections failing with HTTP 500 Internal Server Error
Description: Connections were failing due to a source-side issue. Qualtrics status page: https://status.qualtrics.com/
Timeline: Issue started on Nov 6th 00:08 AM UTC and resolved on Nov 6th 05:09 AM UTC
Cause: This is a source-side issue, "XM Directory issues in Eastern US Region," which was causing an "HTTP 500 Internal Server Error" and connection failures.
Resolution: There was no change in our code; connections started to succeed once the source-side issue was resolved.
Posted Nov 06, 2025 - 05:35 UTC
Monitoring
Qualtrics has marked the incident as resolved, and the connection failure count is starting to decrease. We are monitoring the connections.
Posted Nov 06, 2025 - 05:18 UTC
Update
We identified that connections are failing due to a source-side issue. Qualtrics status page: https://status.qualtrics.com/
Posted Nov 06, 2025 - 03:27 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Nov 06, 2025 - 03:20 UTC
This incident affected: Support connectors (Qualtrics).