3rd Party: Some Box Connections are failing with HTTP "429 Too Many Requests" errors

Incident Report for Fivetran

Resolved

We have resolved this incident.

Incident Summary:

Description:
We identified an issue in some Fivetran's Box connections failing their sync runs with HTTP "429 Too Many Requests" errors.

Timeline:
Incident Start time: 2026:02:24 23:35 UTC
Incident End time: 2026:02:25 00:02 UTC

Cause:
The sync runs failures occurred to an issue in Box's API. Box created a status page for this issue, and they deployed measures to fix the API errors.

Box status page: https://status.box.com/incidents/yb6gsksvbkzf

Resolution:
Box has resolved their incident, and our affected Box connection sync runs have recovered.
Posted Feb 25, 2026 - 03:30 UTC

Monitoring

3rd Party: Box has resolved their incident. We are seeing connections recover, and we are monitoring as new sync runs trigger.
Posted Feb 25, 2026 - 00:20 UTC

Update

This issue is occurring due to an incident on Box's end.

More details are available on Box's status page: https://status.box.com/incidents/yb6gsksvbkzf.

We are monitoring Box's updates as they work through their incident.
Posted Feb 24, 2026 - 23:54 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Feb 24, 2026 - 23:50 UTC
This incident affected: File connectors (Box).