Resolved: We've resolved the issue. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.
Incident Summary: We identified an issue with the Amazon Ads connector which started failing with the error: Setup test failed with java.lang.IllegalArgumentException: No enum constant com.fivetran.flag.FlagName.AmazonAdsViewProfiles.
Description: We identified a code issue that caused sync failures for some connectors due to a missing feature flag. This resulted in setup errors during connector sync.
Timeline: Incident Start time: 2025-05-22 10:22 UTC Incident End time: 2025-05-22 15:17 UTC
Root Cause: The sync failures were caused by a code issue related to a recently introduced feature flag, which led to error.
Resolution: The issue was resolved by properly configuring the missing feature flag. After the fix was deployed, affected connectors began syncing successfully.
Posted May 22, 2025 - 15:17 UTC
Monitoring
A fix has been implemented, and we are monitoring the results.
Posted May 22, 2025 - 12:15 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 22, 2025 - 10:24 UTC
Identified
Connectors are failing with the message "Setup test failed with "java.lang.IllegalArgumentException: No enum constant com.fivetran.flag.FlagName.AmazonAdsViewProfiles"
Posted May 22, 2025 - 10:22 UTC
This incident affected: Marketing connectors (Amazon Ads).