Some Box Connections are failing with HTTP "429 Too Many Requests" errors

Incident Report for Fivetran

Resolved

Description:
Some Box connections unexpectedly failed their sync runs, but recovered on subsequent runs.

Timeline:
Incident Start: 2026-02-23 at 16:30 UTC
Incident End: 2026-02-23 at 18:00 UTC

Cause:
The issue appears to be caused by a temporary error in our credential handling service, but we are continuing to investigate this post incident resolution.

Resolution:
The App Store Connect Reporter is now available, and syncs are succeeding normally.
Posted Mar 23, 2026 - 23:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2026 - 20:40 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Mar 23, 2026 - 20:10 UTC
This incident affected: File connectors (Box).