Description: We identified an issue where SAP ERP on HANA Connector sync is failing due to a JSON Deserialization Error.
Timeline: This issue began on November 17th 2025, at 5:21 UTC and was resolved on November 17th 2025, at 11:46 UTC.
Cause: A recent update to the serialization method caused the failures.
Resolution: The recent changes have been reverted, and the connector syncs are now successful.
Posted Nov 17, 2025 - 11:55 UTC
Update
The hotfix has been deployed, and connectors are recovering. We will keep monitoring all impacted connectors.
Posted Nov 17, 2025 - 08:50 UTC
Monitoring
We have deployed a hotfix for this issue. Once the hotfix has gone live, we will continue to monitor all affected connectors until they resume their normal sync functionality.
Posted Nov 17, 2025 - 08:01 UTC
Update
The issue has been identified and we are working to resolve it.
Posted Nov 17, 2025 - 06:48 UTC
Identified
SAP ERP on HANA Connector sync is failing with the following error: "com.fasterxml.jackson.databind.exc.MismatchedInputException: Cannot deserialize value of type `java.util.LinkedHashMap` from Array value (token `JsonToken.START_ARRAY`)"
Posted Nov 17, 2025 - 06:45 UTC
This incident affected: Database connectors (SAP ERP on HANA).