3rd Party: Multiple Pinterest Ads connectors are failing with error "Internal Server Error (500) retry count of 3 exceeded"
Incident Report for Fivetran
Resolved
We have resolved this incident.
Posted May 14, 2024 - 18:37 UTC
Update
We have added a fix to handle the 500 error returned from the Pinterest API. If a 500 error is returned from API calls, the connector skips these endpoints and will throw a Warning in the UI and Connector Log Events in the Platform Connector.

When these 500 errors stop, the connector will continue to sync these endpoints from the point it left off.
Posted May 14, 2024 - 16:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 14, 2024 - 15:42 UTC
Update
Our testing thus far has identified that the Connectors' queries to the endpoint "resources/targeting/APPTYPE" are failing with a "500 Internal Server Error". We have raised a Ticket with Pinterest to help resolve this error.

We are working on a workaround to skip this endpoint until a solution for the error is in place.
Posted May 14, 2024 - 09:12 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted May 14, 2024 - 03:27 UTC
This incident affected: Marketing connectors (Pinterest Ads).