3rd Party: Ramp Connections failing due to invalid pagination URL

Incident Report for Fivetran

Resolved

Incident Summary

Description:
Ramp syncs were failing with a WebApplicationException, returning an HTTP status code of 1000.

Timeline:
The issue began on December 30, 2025, at approximately 7:50 PM UTC and was resolved on December 31, 2025, at approximately 3:00 AM UTC.

Cause:
The issue was caused by an incorrect pagination URL returned by the source system, resulting in connection errors during the sync.

Resolution:

We have changed the pagination strategy from URL-based key to ID-based key pagination. After this fix, Ramp connections sync successfully.
Posted Dec 31, 2025 - 04:32 UTC

Update

The hotfix has been successfully merged. Syncs are now running successfully, and we are monitoring the connections.
Posted Dec 31, 2025 - 04:04 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 31, 2025 - 03:20 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Dec 31, 2025 - 01:05 UTC
This incident affected: Finance connectors (Ramp).