3rd Party: Some Amazon Selling Partner connectors are failing with the error "Service Unavailable"

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels, and affected connectors are syncing successfully.

Incident Summary
Description: We identified an issue for the Amazon Selling Partner service, which resulted in syncs failing with the error "Service Unavailable"

Timeline: This issue began on June 27, 2025 13:00 UTC and was resolved on Jul 01, 2025 01:50 UTC

Cause: Issue occurred from the source side, causing Amazon Selling Partner APIs to fail with "Service unavailable" exception.

Resolution: We have added a retry logic allowing API endpoints to retry in case of failures. Once these changes took effect, sync failures subsided, and connectors began syncing successfully.
Posted Jul 01, 2025 - 07:24 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 01, 2025 - 06:00 UTC

Update

We are still awaiting a response from the Amazon Selling Partner team regarding the issue. Our engineering team continues to monitor the situation closely. We will provide further updates as soon as we receive more information.
Posted Jun 30, 2025 - 15:19 UTC

Update

Our engineering team has reached out to the Amazon Selling Partner team regarding this issue, and we are currently awaiting their response. We will keep you informed of the next steps as soon as we hear back from them
Posted Jun 28, 2025 - 04:32 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Jun 27, 2025 - 18:55 UTC
This incident affected: Sales connectors (Amazon Selling Partner).