This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.
Incident Summary
Description:
Some Greenhouse connectors began to fail with either a NullPointerException or because the text format [null] was appearing in some date-time format columns. This was due to a recently introduced, incorrect regex transformation as well as improperly handled null webhook events.
Timeline:
This issue began on Justly 29, 2025, at 09:48 UTC and was resolved on July 30, 2025, at 17:08 UTC.
Cause:
We recently identified incorrect regex transformations that caused sync failures. Compounding this, the system encountered null webhook events, which were not correctly handled.
Resolution:
The incorrect regex was removed, and robust null event handling was implemented for webhooks.
Posted Jul 31, 2025 - 00:18 UTC
Monitoring
A fix has been implemented and we are monitoring the results
Posted Jul 30, 2025 - 18:16 UTC
Update
A fix has been raised and is now in the testing phase to confirm stability.
Posted Jul 30, 2025 - 14:46 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 30, 2025 - 07:00 UTC
Identified
We’re actively investigating sync issues impacting some Greenhouse connectors.
Posted Jul 30, 2025 - 06:55 UTC
This incident affected: Human Resources connectors (Greenhouse).