Fivetran: Xero Connectors Impacted by Authentication Failures

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.

Incident Summary
Description:
A number of Xero connectors were failing with authentication errors, preventing successful syncs.

Timeline:
This issue began on June 23, 2025 around 04:00 pm UTC and was resolved on June 24, 2025 at 5:30 am UTC.

Cause:
The issue was introduced by a recent code change related to Hybrid deployment, which inadvertently omitted a condition necessary to persist credentials to the database. As a result, refresh tokens were not updated correctly, leading to authentication failures across impacted connectors.

Resolution:
The problematic change was reverted via a hotfix. While this has stopped further failures, impacted connectors still contain outdated credential information. Affected users have been notified and are being asked to one time re-authorize their Xero connections to fully restore functionality.
Posted Jun 25, 2025 - 07:26 UTC

Monitoring

We have sent a communication email outlining the steps required to complete the reauthorization process. If any of your Xero connections are currently failing, please proceed with reauthorizing them to restore sync functionality.
Posted Jun 24, 2025 - 20:47 UTC

Update

The fix has been successfully implemented. To resume normal sync operations, a one-time re-authorization of the connector is required. Once re-authorized, the connector should begin syncing data as expected.
Posted Jun 24, 2025 - 08:26 UTC

Identified

We have identified the root cause of the issue causing Xero connectors to fail with the following error: "Please re-authorise." A fix is currently in progress, and we will provide further updates soon.
Posted Jun 24, 2025 - 04:26 UTC
This incident affected: Finance connectors (Xero).