Many Connector SDK connections failed syncs with error "Failed to pull image after max retries"

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.

Incident Summary
Description:
We identified an issue for Connector SDK which resulted in syncs failing with a "Failed to pull image after max retries" error.

Timeline:

Incident Start Time: 2026-05-04 21:51 UTC
Incident End Time: 2026-05-04 23:49 UTC

Cause:
An automated cleanup process removed a required image used for Connector SDK sync runs.

Resolution:
Fivetran redeployed the image, which restored the Connector SDK service.
Posted May 05, 2026 - 02:35 UTC

Update

We are continuing to monitor the results
Posted May 04, 2026 - 23:56 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 04, 2026 - 23:40 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted May 04, 2026 - 23:40 UTC
This incident affected: Function connectors (Connector SDK).