Fivetran : All DBT and Quickstart Transformation models are failing

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected models are syncing successfully.

Incident Summary

Description:
We identified an issue for DBT and Quickstart Transformation which resulted in models failing with below error.

Error :
ValueError: Proto enum SubmitSQLResultType has values not defined in Python enum SubmitSQLResultType: ['GET_MODIFICATION_INFO']. All proto enum values must have corresponding Python enum members

Timeline:
This issue began on 5th March, 10:02 AM UTC and was resolved on 5th March, 11:22 AM UTC.

Cause:
A recently released dbt image introduced a compatibility issue with a dependent internal service, which led to service disruption.

Resolution:
We have rolled back the affected images to the previous stable version to restore services.
Posted Mar 05, 2026 - 13:04 UTC

Monitoring

A fix has been Implemented and we are monitoring the results on our end.
Posted Mar 05, 2026 - 11:33 UTC

Identified

We have identified that the models are failing with the below error.

Error: ValueError: Proto enum SubmitSQLResultType has values not defined in Python enum SubmitSQLResultType: ['GET_MODIFICATION_INFO']. All proto enum values must have corresponding Python enum members.
Posted Mar 05, 2026 - 11:05 UTC
This incident affected: Systems (General Services).