3rd Party: WorkRamp Connections failing with Status Code 400

Incident Report for Fivetran

Resolved

The issue has been resolved. Instance rates have returned to normal levels, and affected connectors are syncing successfully.

Description:
WorkRamp connections were failing with HTTP status code 400.

Timeline:
The issue started on December 12 at 04:40 PM UTC and was resolved on December 13 at 08:00 AM UTC.

Root Cause:
The failures were caused by a pagination issue with the WorkRamp endpoint
/api/v1/users/:user_id/assignments/.

Resolution:
The issue was resolved by adding a pagination end strategy to prevent the error.
Posted Dec 13, 2025 - 10:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 13, 2025 - 08:05 UTC

Update

This is due to a pagination issue with the WorkRamp endpoint /api/v1/users/:user_id/assignments/, and we are currently working on a fix.
Posted Dec 13, 2025 - 06:30 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Dec 13, 2025 - 06:00 UTC
This incident affected: Human Resources connectors (WorkRamp).