We have confirmed that instance rates have returned to normal and connectors are now syncing successfully.
Incident Summary Description: HubSpot connectors were failing with a reconnect error: "We were denied access to HubSpot. Please check the accuracy of your credentials."
Timeline: Start: 20:30 UTC Resolution: 08:30 UTC
Cause: A change introduced on HubSpot’s side caused unexpected 403 errors from the /property/{crm_object} endpoint.
Resolution: HubSpot identified the issue and deployed a fix on their end, restoring normal functionality.
Posted Aug 20, 2025 - 10:48 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 20, 2025 - 10:17 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 20, 2025 - 08:08 UTC
Update
We have merged a hotfix to skip the affected endpoints. We will monitor the connections once the hotfix is deployed
Posted Aug 20, 2025 - 07:02 UTC
Update
We are currently seeing failures for HubSpot connectors due to changes in source API requirements for certain Engagement CRM objects (Calls, Notes, Meetings, Tasks). Connections are returning 403 errors when accessing affected endpoints.
Our team has contacted the HubSpot team and is working on a temporary fix, skipping these objects until we receive further clarification. We will provide updates as we learn more.
Posted Aug 20, 2025 - 04:05 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Aug 20, 2025 - 01:25 UTC
This incident affected: Sales connectors (HubSpot).