This incident has been resolved. We have observed that destination setup tests are now running successfully and operating as expected.
Incident Summary
Description: We identified an issue impacting destination setup tests, causing them to fail across regions.
Timeline: This issue began on 2026-03-10 at 02:40 UTC and was resolved on 2026-03-10 at 19:20 UTC.
Cause: The issue was caused by a faulty pull request related to a new feature, which introduced changes to the token registration process used for setup test jobs.
Resolution: Engineering identified the root cause and reverted the recent changes to restore the original token registration model. Following the revert and hotfix deployment, destination setup tests resumed functioning normally.
Posted Mar 10, 2026 - 19:15 UTC
Monitoring
A fix has been implemented, and we are currently monitoring the results.
Posted Mar 10, 2026 - 17:59 UTC
Update
We have identified the root cause of the issue and are actively working on a hotfix to resolve it.
Posted Mar 10, 2026 - 15:41 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 10, 2026 - 11:23 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Mar 10, 2026 - 11:15 UTC
This incident affected: Systems (General Services).