3rd Party: Multiple Pinterest connectors are failing with 500 internal error

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.

Incident Summary
Description:
We identified an issue for pinterest_ads which resulted in syncs failing with a 500 Internal Server Error.

Timeline:
This issue began on 2025-07-18 at 11:20 PM UTC and was resolved on 2025-07-19 at 1:10 AM UTC.

Cause:
The failure was due to an outage on Pinterest’s end.
https://www.pintereststatus.com/incidents/kybz9g92ghkk

Resolution:
The outage was resolved by Pinterest
Posted Jul 19, 2025 - 07:26 UTC

Monitoring

Pinterest had an outage on their end, which has now been resolved. We are currently monitoring the recovery of connectors.
https://www.pintereststatus.com/incidents/kybz9g92ghkk
Posted Jul 19, 2025 - 05:39 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Jul 19, 2025 - 03:15 UTC