Delayed Time in fivetran_audit table
Incident Report for Fivetran
Postmortem

Timeline:

Identified: January 08, 2021 at 08:28 UTC

Fix deployed/Monitoring: January 08, 2021 at 18:01 UTC

Resolved: January 09, 2021 at 03:16 UTC

Issue:

_fivetran_audit table is created for each connector and it’s supposed to contain 1 row for each table that Fivetran replicates to destination in any given sync. This row will contain information regarding table name, sync start/end times, progress, etc.

There was a recent update which caused our connectors to only include a single record per sync in the _fivetran_audit table, even in the event of multiple tables synced.

Root Cause:

A recent update produced a bug wherein the new rows in _fivetran_audit table being assigned the same primary key, thereby causing them to deduplicate into 1 record.

For example, if Connector A is flushing data for 5 tables in a given sync, there should be 5 records in the _fivetran_audit table (i.e. 1 row for each table that was synced). However, due to a bug, there was only 1 record added to the _fivetran_audit table because all 5 of the rows were assigned the same Primary Key and were, therefore, consolidated into 1 record.

Resolution:

The recent bug has been fixed and changes depoloyed.

Posted Jan 11, 2021 - 17:44 UTC

Resolved
This incident has been resolved.
Posted Jan 09, 2021 - 03:16 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 08, 2021 - 18:01 UTC
Identified
The fivetran_audit table is not being updated with the sync details of all tables. The issue has been identified and we are working towards a fix for the same.
Posted Jan 08, 2021 - 08:28 UTC
This incident affected: Replication Servers.