Fivetran: Pardot connector syncs were failing with the Invalid Token within the setup tests.

Incident Report for Fivetran

Resolved

Incident Summary
Description:
We encountered an issue affecting Pardot connectors, syncs were failing with Invalid access token error.

Timeline:
This issue first started occurring 2025-07-09 00:19:59 UTC and was resolved on 2025-07-09 14:50:00 UTC.

Root Cause:
The issue was caused by a bug introduced in a recent code change.

Resolution:
We resolved the issue by deploying a fix which helped resolving the issue
Posted Jul 10, 2025 - 12:30 UTC

Monitoring

The failure was related to the access token being invalid, this happened due to change implemented recently on our end causing the syncs to fail, we identified the same and deployed a fix to help resolve the errors.
Posted Jul 10, 2025 - 12:30 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Jul 10, 2025 - 12:30 UTC