This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.
Incident Summary Description: We identified an issue for Reddit Ads which resulted in syncs failing with a "HTTP 500 (Internal Server Error)" error.
Timeline: This issue began on April 1st at 16:00 UTC and was resolved on the same day at 21:30 UTC.
Cause: The Reddit Ads API started returning 500 failures to connector requests.
Resolution: The 500 errors were resolved source-side and a hotfix has been implemented to catch similar failures in the future.
Posted Apr 01, 2026 - 23:19 UTC
Monitoring
The issue has been resolved from Reddit and a hotfix has also been released to avoid sync failures due to 500 errors.
We will continue monitoring for any further failures.
Posted Apr 01, 2026 - 22:26 UTC
Update
We are seeing HTTP 500 (Internal Server Error) responses from Reddit’s Ads API when attempting to create reporting jobs. This occurs on the report creation endpoint and is affecting multiple connectors.
Posted Apr 01, 2026 - 19:50 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Apr 01, 2026 - 19:30 UTC
This incident affected: Marketing connectors (Reddit Ads).