Xero Connectors failing due to 400 Bad request
Incident Report for Fivetran
Resolved
We have resolved this incident.
Posted Jun 17, 2021 - 15:50 UTC
Monitoring
We have released a fix to temporarily skip the sync of the "overpayment" table if there are any errors returned for it.

Next Steps:
We are waiting for Xero support to reply on the resolution of the root cause of this issue. Following the resolution, we will remove the temporary table skip.
Posted Jun 17, 2021 - 15:09 UTC
Update
Some connectors are failing with an error containing "Primary Key overpaymentID is null in object".
This is caused by the Xero API incorrectly returning the OverpaymentId values as null. The Xero documentation informs that this should be a unique value:
https://developer.xero.com/documentation/api/accounting/overpayments#get-overpayments.

We are seeing this get resolved by itself for some customers and we are in the process of reaching out to Xero Support to resolve this.
Posted Jun 17, 2021 - 13:09 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Jun 17, 2021 - 08:00 UTC