Fivetran: Few Github Connectors are Failing

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.

Incident Summary

Description:
We identified an issue for Few Github Connectors which resulted in syncs failing with a ‘Your organization has disabled Copilot Metrics API access. Enable it in GitHub settings to access this endpoint’ error.

Timeline:
This issue began on 2025-05-20 at 06:48 UTC and was resolved on 2025-05-20 at 09:15 UTC.

Cause:
The root cause is improper error handling for endpoints to which we do not have access.

Resolution:
We had applied a fix on the connection's code.
Posted May 20, 2025 - 12:33 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 20, 2025 - 09:38 UTC

Identified

We have identified that some GitHub Connectors are failing with the error: ‘Your organization has disabled Copilot Metrics API access. Enable it in GitHub settings to access this endpoint.’
Posted May 20, 2025 - 08:53 UTC
This incident affected: Engineering connectors (GitHub).