GA4 Export: Connectors are reverting to old schema

Incident Report for Fivetran

Resolved

This incident has been resolved. We are now seeing that connectors have reverted to the correct schema. As the next step, we will send customer communications to initiate a partial resync for all impacted customers. This will help restore data integrity for the affected period.


Incident Summary

Description:
We identified an issue affecting GA4 Export connectors, where the schema had unintentionally reverted to an earlier version. As a result, event tables were syncing null values for "params" and "user_properties" columns.

Timeline:
Incident Start: April 16, 2025 (UTC)
Incident End: April 22, 2025, at 7:00 PM UTC

Cause:
A recent product change introduced a local variable within an internal service, which caused the connector to fall back to an outdated ERD version starting April 16.


Resolution:
Our Engineering team deployed a hotfix to ensure the connector consistently uses the latest ERD version. New data is now syncing correctly, and all affected tables are being populated as expected.
Posted Apr 22, 2025 - 20:06 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Apr 22, 2025 - 19:47 UTC

Update

We are actively working on resolving the remaining schema discrepancies and data integrity issues to ensure accurate and consistent data replication.
Posted Apr 22, 2025 - 13:46 UTC

Update

A fix has been implemented to ensure the connectors replicate data to the event and item tables as intended.
We are continuing to work on resolving the remaining schema and data integrity issues.
Posted Apr 22, 2025 - 10:03 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 22, 2025 - 08:18 UTC

Identified

We've identified the root cause of the issue impacting GA4 Export connectors. Our engineering team is currently working on deploying a hotfix to resolve it.
Posted Apr 22, 2025 - 04:07 UTC

Investigating

We are currently investigating this issue.
Posted Apr 22, 2025 - 00:58 UTC