Description: Iterable Connectors failed with IllegalArgumentException because source started to return a JSON value instead of a String.
Timeline: The Iterable connector issue started on December 17, 2025, at 2:49 PM UTC and was resolved on December 18, 2025, around 1:50 am UTC.
Cause: Abrupt change in datatype for a field from source.
Resolution: A fix was raised to deserialize the field when a JSON object appears. Once the fix was deployed, the connections started syncing successfully.
Posted Dec 18, 2025 - 05:35 UTC
Monitoring
A hotfix has been deployed and we are monitoring the syncs now.
Posted Dec 18, 2025 - 01:57 UTC
Update
We have identified that the issue stems from a change on the source side where a webhook record contains a value that is expected to be of String type is being returned as JSON, which is causing sync failures for the Iterable connectors. Our engineering team is actively working on a fix.
Posted Dec 18, 2025 - 00:21 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Dec 17, 2025 - 23:25 UTC
This incident affected: Marketing connectors (Iterable).