This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.
Incident Summary Description: We identified an issue for some Workday_HCM connectors which resulted in syncs failing with a `QUOTED_IDENTIFIERS_IGNORE_CASE` error.
Timeline: This issue began on October 25th at 14:00 UTC and was resolved on October 26th at 10:00 UTC.
Resolution: This issue was resolved by updating the schema migration code.
Posted Oct 26, 2024 - 10:23 UTC
Update
We have deployed a fix for this issue and failing connectors are currently returning to normal sync functionality. We will continue to monitor all affected connectors and check in with some updates accordingly.
Posted Oct 26, 2024 - 09:24 UTC
Monitoring
Whilst we continue to work on a fix for the issue, we have identified a workaround that will allow failing connectors to sync successfully. Please drop the `JOB_REQUISITION_BACKUP_2024_10_28` table in your destination, this table does not contain any data. Once this step is completed, your sync will return to its normal functionality.
Posted Oct 26, 2024 - 00:10 UTC
Update
We have identified the root cause of the observed failures. As part of a recent schema migration, Workday_HCM connectors are attempting to rename the `JOB_REQUISITION` table to `JOB_REQUISITION_BACKUP_2024_10_28`. This action is resulting in the observed failures for some connectors. We are currently working on a fix for the issue.
Posted Oct 25, 2024 - 23:00 UTC
Identified
We have identified an issue where some Workday_HCM connectors are failing with a `QUOTED_IDENTIFIERS_IGNORE_CASE` exception. We are currently investigating this issue in more detail and will provide additional updates accordingly.
Posted Oct 25, 2024 - 20:55 UTC
This incident affected: Human Resources connectors (Workday HCM).