Fivetran: Some of Google Ads connections are failing wit Null primary key found while syncing table campaign_shared_set_history after update to Google Ads API v20

Incident Report for Fivetran

Resolved

Incident Summary

Description:
We encountered an issue where some of Google Ads connections are failing with Null primary key found while syncing table campaign_shared_set_history after update to Google Ads API v20

Timeline:
The issue started on Aug 01, 2025, at 11:30  UTC and was resolved on Aug 01, 2025, at 5:00 PM UTC

Cause:
The issue was caused due to some changes observed with the upgrade and there were possibly problems with the code to handle the same.

Resolution:
The issue has been fully resolved, and all the affected connectors have returned to normal functionality.
Posted Aug 01, 2025 - 18:04 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 01, 2025 - 16:40 UTC

Update

With upgrade to v20 we started to receive deletes for CampaignSharedCriterion, and there was a problem within the logic handling the same between the Deletion Key definition and Primary Key definition for the campaign_shared_set_history as something related to the primary key changed with the upgrade in the Google APIs.
Posted Aug 01, 2025 - 16:39 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Aug 01, 2025 - 16:30 UTC
This incident affected: Marketing connectors (Google Ads).