Fivetran: Some Snowflake destination setup tests run using Fivetran's API are failing with “Internal server error: failed to perform setup tests” errors.

Incident Report for Fivetran

Resolved

This incident has been resolved.

Incident Summary

Description:
A recent Fivetran feature release caused some Snowflake destination setup tests to fail with the “Internal server error: failed to perform setup tests” error when they were created with API

Timeline:
This issue began on July 9th, 2025 at 5 PM UTC and was resolved on July 10th, 2025 at 12:30 AM UTC.

Cause:
We determined that a new feature release introduced an unintended behaviour.

Resolution:

A rollback of the problematic feature was deployed, and service was fully restored as of July 10th, 2025, at 12:30 AM UTC.
Posted Jul 10, 2025 - 02:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 10, 2025 - 02:30 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Jul 09, 2025 - 22:15 UTC