3rd Party: Survey Monkey connections are failing with Validation Error on Surveys endpoint

Incident Report for Fivetran

Resolved

This incident has been resolved. We observed instance error rates returning to normal levels and connector syncs are running fine.

Incident Summary
Description:
We identified an issue where Survey Monkey connector syncs were failing on the /surveys endpoint with a 400 Bad Request error.

Timeline:
The issue began on February 19 at 11:18 AM UTC and was resolved at 14:57 PM UTC.

Cause:
The failures occurred due to a change on the source side to the sort_order filter values, which were updated from ASC/DESC to asc/desc.

Resolution:
We implemented a fix to update the sort_order filter to use asc/desc for the /surveys endpoint. Connector syncs are now running normally.
Posted Feb 19, 2026 - 15:45 UTC

Monitoring

A fix has been implemented on our end and we are monitoring the connections.
Posted Feb 19, 2026 - 14:53 UTC

Identified

We have identified that the connections are failing with the below error on /surveys endpoint.

Error : "HTTP Status: 400 Bad Request\n[{\"exception\":\"ValidationError\",\"message\":\"'ASC' is not one of ['asc', 'desc']\",\"field\":\"sort_order\"}]
Posted Feb 19, 2026 - 12:40 UTC
This incident affected: Systems (General Services).