This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.
Incident Summary
Description: We identified an issue affecting Google Campaign Manager 360 (DCM) connectors that caused syncs to fail with the following error:
``You cannot pass in different TableDefinition object for the same table after the first time any core operation is called.``
Timeline: The issue began on June 13, 2025 at 11:30 AM UTC and was resolved on June 13, 2025 at 05:00 PM UTC.
Cause: The syncs were failing due to a mismatch in how table information was being handled during the process.
Resolution: We made a change to ensure table information stays consistent throughout the sync. The fix has been deployed and affected connectors are syncing successfully.
Posted Jun 13, 2025 - 18:27 UTC
Monitoring
We have deployed a fix for this issue.
We will continue to monitor all affected connectors until they resume their normal sync functionality.
Posted Jun 13, 2025 - 17:24 UTC
Update
We are currently investigating an issue impacting several Google Campaign Manager 360 (CM360) connectors. Affected connectors are failing to sync due to a schema conflict error. The error message observed is:
"You cannot pass in different TableDefinition object for the same table after the first time any core operation is called."
Our engineering team has identified the cause and is actively working on a resolution.
Posted Jun 13, 2025 - 15:29 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Jun 13, 2025 - 15:25 UTC
This incident affected: Marketing connectors (Google Campaign Manager 360).