Fivetran: Google Cloud Function connectors failing with the error “Setup test failed with "java.lang.IllegalArgumentException: argument "content" is null"”
Description: A recent Fivetran feature release caused sync failures and setup test failures for Google Cloud Functions connectors with the error: "Setup test failed with java.lang.IllegalArgumentException: argument "content" is null"
Timeline: Issue began: July 8th, 2025, 2:00 AM UTC Issue resolved: July 8th, 2025, 4:33 AM UTC
Cause: We determined that a new feature release introduced an unintended dependency on an optional configuration field within the Google Cloud Functions connector. For connectors where this field was previously unset, the new code incorrectly attempted to access or utilize a non-existent value. This led to system exceptions during the connector's setup test, preventing syncs from succeeding.
Resolution: A rollback of the problematic feature was deployed, and service was fully restored as of 4:33 AM UTC.
Posted Jul 08, 2025 - 16:17 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2025 - 16:00 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Jul 08, 2025 - 09:50 UTC
This incident affected: Function connectors (Google Cloud Functions).