Some Oracle connectors are failing with the error "Failed to perform Incremental update for table SCHEMA.TABLE after 3 attempts"
Incident Report for Fivetran
Resolved
We have resolved this incident.
Posted Jul 12, 2022 - 20:39 UTC
Monitoring
We have deployed a change that correctly excludes Oracle connectors from making any Flashback queries. Affected connectors should recover automatically and continue incremental syncs at the start of the next sync.

We are continuing to monitor connectors for recovery.
Posted Jul 12, 2022 - 17:31 UTC
Update
We have identified the issue as an incorrect attempt to issue a Flashback query that results in a permissions error. We're moving forward with a fix for this issue.
Posted Jul 12, 2022 - 16:46 UTC
Update
We are continuing to investigate the cause for some Oracle connectors failing with an ORA-01031: insufficient privileges error during incremental updates.
Posted Jul 12, 2022 - 16:13 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Jul 12, 2022 - 14:21 UTC
This incident affected: Database connectors (Oracle).