Incident Summary Description: We identified an issue with some of our S3 Data Lake warehouses, which resulted in syncs failing with a reconnect warehouse error.
Timeline: This issue began on July 9th, 2025 at 6 AM UTC and was resolved on July 9th, 2025 at 8 PM UTC.
Cause: The issue was introduced by a recent code change related intended to improve the Data Lakes set up process, which inadvertently made the prefix path in the IAM policy into a mandatory field. As a result, we could no longer connect to destinations where the prefix path was empty in the policy.
Resolution: The problematic change was reverted via a hotfix.
Posted Jul 10, 2025 - 02:52 UTC
Monitoring
We have applied a fix that resolves the issue causing the reconnect tasks. We will continue to monitor all affected connectors until they resume their normal sync functionality.
Posted Jul 09, 2025 - 20:26 UTC
Update
We have identified the root cause of the issue causing S3 Data Lake warehouses to throw a reconnect alert. A fix is currently in progress, and we will provide further updates soon.
Posted Jul 09, 2025 - 19:32 UTC
Identified
We have identified an issue with our S3 Data Lake warehouses, which is causing syncs to fail with a reconnect task. We will continue to investigate and provide additional updates.