3rd Party: Twitter Ads and Twitter Organic connector sync failures due to Bad Authentication data (code 215) error

Incident Report for Fivetran

Resolved

This incident has been resolved.

Incident Summary

Description: Twitter API started returning a Bad Authentication data error (code 215) while fetching successful async job results.

Timeline: Impact start time around April 11th, 9:30 PM UTC to  April 11th 01:57 UTC

Cause: 3rd party error on Twitter side

Resolution: We have implemented a workaround that skips the problematic endpoints for problematic accounts when this error occurs, and connectors are now back to normal.
Posted Apr 12, 2026 - 02:36 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Apr 12, 2026 - 00:07 UTC

Update

Connectors are failing with a “Bad Authentication data” error (code 215) while fetching successful async job results.
Posted Apr 11, 2026 - 23:18 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Apr 11, 2026 - 22:45 UTC
This incident affected: Marketing connectors (Twitter Ads).