Some Recharge connectors failing with unexpected eventType errors
Incident Report for Fivetran
Resolved
This incident has been resolved.

We will continue to work with the Recharge team to get a better understanding of why did we start receiving these unrecognized events unexpectedly and how to process them in the future.
Posted Dec 10, 2021 - 16:35 UTC
Monitoring
We have deployed the code fix and are currently monitoring the results.
Posted Dec 10, 2021 - 14:34 UTC
Update
We are in process of deploying another code fix that will help resume capturing the deletes, except the unrecognized event being sent by Recharge.

We are reaching out to Recharge support as well to get more insights into this event type.
Posted Dec 10, 2021 - 07:37 UTC
Update
The interim solution has been deployed to production, and we are starting to see syncs complete successfully. We are still working on a long-term solution that fully addresses this issue.
Posted Dec 10, 2021 - 02:32 UTC
Update
We have identified an interim solution that will allow syncs to resume, however capture data deletes will be delayed. We are working on a long-term solution in parallel that will allow syncs and delete capture to function as expected.
Posted Dec 09, 2021 - 22:57 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Dec 09, 2021 - 21:57 UTC