Fivetran: Google Ads connector rescheduling with message: Developer token quota exhausted

Incident Report for Fivetran

Resolved

This incident has been resolved.

Incident Summary
Description:
We encountered an issue where the connector syncs were getting rescheduled with the message: 'Developer token quota exhausted' due to the addition of the new table: Search_Term_Keyword_Stats.
Timeline:
The issue started on April 24, 2025, at 10:35 UTC and was resolved on April 25, 2025, at 09:00 UTC.
Cause:
The issue was caused by an change made to the connector to add the new table Search_Term_Keyword_Stats.
Resolution:
The issue has been fully resolved, and all affected connectors have returned to normal functionality.
Posted Apr 25, 2025 - 11:35 UTC

Monitoring

We have deployed a fix to actually revert the changes made, the connectors are now back to normal and we are monitoring the same.
Posted Apr 25, 2025 - 10:09 UTC

Identified

The connector sync rescheduled with the message: 'Developer token quota exhausted' due to the addition of the new table: Search_Term_Keyword_Stats. Our engineering team is actively working on a fix for this issue.
Posted Apr 25, 2025 - 07:29 UTC

Investigating

We are currently investigating this issue.
Posted Apr 25, 2025 - 07:00 UTC
This incident affected: Marketing connectors (Google Ads).