3rd Party: Delays observed in logs sent to external logging services

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that the delays in sending logs to the external logging services have reduced, and the time taken to send the logs has returned to normal levels.

Incident summary

Description:
We had identified mass request timeouts on one of our External logging services, New Relic. Due to these request timeouts, an observed delay occurred, causing a backlog of log messages that were intended to be sent to all other external logging services.

Timeline:
This issue began on 12th January, 2026, at 16:10 UTC and was resolved on the same day at 19:23 UTC.

Cause:
The outage on the New Relic end contributed to mass request timeouts for Fivetran. This, in turn, caused a backlog of Fivetran's log messages to accumulate, resulting in a delay when sending logs to our external log services.
https://status.newrelic.com/incidents/841wj7g90mdb

Resolution:
Once the incident on the New Relic end was resolved, we also observed that our API requests were being processed and our services were restored to normal log delivery.

Additionally, we are actively implementing architectural improvements to enhance the long-term stability and resilience of this service.
Posted Jan 12, 2026 - 19:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 12, 2026 - 18:10 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jan 12, 2026 - 17:18 UTC

Identified

We have identified delays while logs are sent to external logging services. We are currently investigating to address and resolve this issue.
Posted Jan 12, 2026 - 16:15 UTC
This incident affected: Log connectors (AWS CloudWatch, Datadog Log, Fivetran Platform, Google Cloud Logging, Azure Monitor Log, Splunk Log, Newrelic Log).