This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.
Description: We identified an issue for the Xero connector, which resulted in syncs failing with Error: 're-authorize exception message: HTTP 400 Bad Request'.
Timeline: This issue began on February 26th, 2025 at 09:00 UTC and was resolved on February 28, 2025 at 12:17 UTC.
Cause: The Connectors were failing when the client secret for the Fivetran public app was corrupted, resulting in token refresh failures for customers using this method.
Resolution: To mitigate the issue from our side, We have generated a new client secret for the Fivetran public app and updated XERO_OAUTH2_SECRETS accordingly.
Posted Feb 28, 2025 - 12:17 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 28, 2025 - 09:21 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 28, 2025 - 05:45 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Feb 27, 2025 - 22:31 UTC
This incident affected: Finance connectors (Xero).