3rd Party: Google Display & Video 360 connections are failing with error "Unknown Client Failure"

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels, and affected connectors are syncing successfully.

Incident Summary

Description:
We identified an issue with Google Display & Video 360 connections, which resulted in sync failures with an "Unknown Client Failure" error.

Timeline:
This issue began on November 28, 2025, at 01:42 UTC and was resolved on November 29, 2025, at 08:43 UTC.

Cause:
This was caused by the Quota limit decreasing from 1.5k to 0.4k requests per minute for the Display & Video 360 API on the third-party side.

Resolution:
We temporarily disabled sync of all metadata tables in the Google Display & Video 360 connector. We will be working on a solution to re-enable them.
Posted Nov 28, 2025 - 12:05 UTC

Update

The latest fix has resolved the issue, and syncs are succeeding as expected. We are continuing to monitor the connections.
Posted Nov 28, 2025 - 05:45 UTC

Update

A new fix has now been implemented, and we are currently monitoring the results.
Posted Nov 27, 2025 - 23:32 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 27, 2025 - 15:08 UTC

Update

We’ve implemented improvements to stabilize DV360 connector performance, and the fix is currently in testing. In parallel, we’re also working with the DV360 API Support team for further resolution. Connectors should run more reliably, and we’ll continue monitoring the situation closely.
Posted Nov 27, 2025 - 14:57 UTC

Update

The issue is caused by a reduced API quota for the Display & Video 360 API on GCP. We are working to restore the quota and are also implementing improvements to better handle per-minute quota limits.
Posted Nov 27, 2025 - 08:57 UTC

Update

We are continuing to investigate the issue
Posted Nov 27, 2025 - 05:01 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Nov 27, 2025 - 02:15 UTC
This incident affected: Systems (General Services).