Fivetran: Multiple Hybrid Deployment Connections are failing

Incident Report for Fivetran

Resolved

Incident Summary

Description:
We identified an issue where Hybrid Deployment connections were failing with a "Failed to generate data key for HD encryption context" or "Failed to receive message length" exception.

Timeline:
This issue began on June 17, 2026, at 08:10 UTC and was resolved on June 17, 2026, at 15:50 UTC.

Cause:
A recent code change introduced an issue affecting Hybrid Deployment connectors, specifically Oracle HVA and SQL Server HVA connectors. As a result, sync jobs for impacted connectors would start and then fail.

Resolution:
We reverted the problematic change and deployed a hotfix. After the fix was deployed, affected connectors began recovering and syncs started succeeding again.
Posted Jun 17, 2026 - 18:06 UTC

Monitoring

We have deployed a fix for this issue.

We will continue to monitor all affected connectors until they resume their normal sync functionality.

Next Expected Update: 3 hours
Posted Jun 17, 2026 - 15:56 UTC

Update

We are continuing to work on a fix for this issue.

Next Expected Update: 1 hour
Posted Jun 17, 2026 - 15:00 UTC

Update

We have identified that this issue was caused by a recent change, and we are currently working on a HotFix.

Next Expected Update: 1 hour
Posted Jun 17, 2026 - 13:33 UTC

Identified

We have identified an issue where Hybrid Deployment Connections are failing with a "Failed to generate data key for HD encryption context" or "Failed to receive message length" exception. We are currently investigating in more detail.

Next Expected Update: 1 hour
Posted Jun 17, 2026 - 12:40 UTC
This incident affected: Systems (General Services).