Fivetran: Multiple SQL Server connections failing with "TLS Protocol Mismatch" Error

Incident Report for Fivetran

Resolved

We have resolved this incident.

Issue:
Multiple SQL Server connections failing with "TLS Protocol Mismatch" Error

Timeline:
This issue began on Aug 26, 2025, at 21:45 UTC and was resolved on Aug 27, 2025, at 04:15 UTC.

Root Cause:
The issue was caused by a bug introduced in a recent code change.

Resolution:
We resolved the issue by rolling back the change, which restored normal functionality.
Posted Aug 27, 2025 - 04:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 27, 2025 - 01:47 UTC

Update

Engineering has identified the issue and are working to resolve it.
Posted Aug 26, 2025 - 22:39 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Aug 26, 2025 - 22:35 UTC
This incident affected: Database connectors (SQL Server).