Fivetran: The Connector SDK Connection state not advancing

Incident Report for Fivetran

Resolved

This incident has been resolved.

Incident Summary

Description:
We identified an issue where the connector SDK connection state is not advancing, resulting in the same data sync for the last few days.

Timeline:
This issue began on April 29, 2026, at 02:08 UTC and was resolved on May 4, 2026, at 13:00 UTC

Cause:
A recent code change caused the issue.

Resolution:
Reverted the changes to resolve the issue.
Posted May 04, 2026 - 13:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 04, 2026 - 12:59 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 04, 2026 - 11:21 UTC

Update

We have identified the root cause and are working on the fix.
Posted May 04, 2026 - 09:55 UTC

Identified

We identified an issue where the connector SDK connection state is not advancing, resulting in the same data sync for the last few days.
Posted May 04, 2026 - 09:35 UTC
This incident affected: Function connectors (Connector SDK).