This incident has been resolved. We have observed that instance rates are returning to normal levels, and affected connectors are syncing successfully.
Incident Summary Description: We identified an issue affecting the TikTok Ads connector, which caused syncs to fail with the error: “Received unknown error with return code -99999. Error: \"Internal Timeout.\"
Timeline: This issue began on 25 January 2026 at 10:04 AM UTC and was resolved on 26 January 2026 at 05:52 AM UTC.
Cause: The failure was triggered on the "Pixel Stats" endpoint, where the TikTok Ads service began returning HTTP 500 errors.
Resolution: We implemented a skip mechanism on the affected endpoint by displaying a warning message in the dashboard, and the connectors continue the sync for the remaining data.
Posted Jan 26, 2026 - 10:58 UTC
Monitoring
Third-party has resolved the issue and syncs are now recovering. We are continuing to monitor the syncs.
Posted Jan 26, 2026 - 07:45 UTC
Investigating
We are seeing that some TikTok Ads connections are still encountering errors (52300, 51010). Our team is actively investigating the issue and is also coordinating with TikTok Ads while we wait for further updates from their side.
Posted Jan 26, 2026 - 02:43 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 26, 2026 - 00:42 UTC
Identified
We have identified an issue with the TikTok Ads connection, where sync jobs are failing due to internal timeouts or connection errors. This appears to have originated from the third-party side; as a result, we have reached out to TikTok Support and are working with them to resolve it.
Posted Jan 25, 2026 - 17:10 UTC
This incident affected: Marketing connectors (Tiktok Ads).